Getting GPS Started

Go down

Getting GPS Started Empty Getting GPS Started

Post  fletchb91 on Mon Jun 14, 2010 12:36 pm

It says no question is too stupid...

I recently got a HTC Touch Pro II (Verizon) and was thinking it might be nice to have the ability to use my phone as a backup or as in an attempt to do a cache on the fly some time. For the most part, I'll stick with my Delorme PN-40 and Pocket Queries...but again it would be a nice backup.

I installed GCzII and the app seems to have installed OK. But when I try to do something with my GPS, it says Com port open failed [COM0: 4800]. What do I need to do to set the GPS up properly to work with GCzII?

Is there a help or configuration document somewhere?



Posts : 1
Join date : 2010-06-14

Back to top Go down

Getting GPS Started Empty Re: Getting GPS Started

Post  acejavelin on Mon Jun 14, 2010 5:41 pm

Your question is not stupid, but I am thinking this is NOT a GCzII issue, but a Verizon issue...

I can't be sure on this as I do not have this phone, and this may be old (and potentially outdated) information but there has been a lot of discussion that Verizon locks the GPSr in their phones in software so that only VZNavigator and other purchased applications can use it. Many people have tried to unlock the GPSr in Verizon smartphones over the years, some have been successful on varied phone models and you could look in the forums at xda-developers, HTCGeeks, and PPCGeeks for more information on loading custom ROM images to unlock the GPSr in the Verizon smartphones.

MANY people have gotten Verizon Windows Mobile smartphones specifically for Geocaching with GCzII, and most of them to my knowledge do not work because of how Verizon locks down the phones so much, a lot of people on Verizon have actually returned them and gotten Android-based phones as most of those seem to have the GPSr unlocked out of the box, but most VZW Blackberry models have the GPS locked as well.

Some users have reported having luck using the GPSr for other applications AFTER purchasing the VZNavigator application, as that seems to unlock the GPSr in some phones.

Basically, try Google Maps, if that works you should be able to get GCzII to work.

BTW, the COM0:4800 is coming from the Windows Mobile Settings\System\External GPS configuration which is where GCzII gets its info from by default (GCzII Menu\GPS\GPS Settings Manage GPS Automatically check box). The External GPS settings needs to be setup correctly for the GPS receiver in your device before using other applications, this allows WM to let multiple applications receive GPS data at the same time via the virtual COM0 port, otherwise if the application talks directly to the GPSr serial port only one application can access it at a time. Remember in WM, the GPSr is just a device that is a serial port dumping GPS data to Windows Mobile, so you need to know the COM port that its using and the speed to set it up and I do not know this information on this device.

Most GSM based phones (AT&T/T-Mobile) and Sprint users do not seem to have this problem, it is a Verizon thing...

Perhaps someone with a Verizon HTC Touch Pro II phone could shed some more light on this specific phone.

EDIT: PS. I did some quick Googling and the above info maybe obsolete as it appears that Verizon has enabled GPS in its devices as of late last year, it seems you need to make sure that the GPS is enabled for this to work. This is from thread on PPCGeeks "goto phone>menu>options>cdma services>location>and turn it on.. its off by default for some reason..." Here is a link to the thread

Last edited by acejavelin on Mon Jun 14, 2010 6:06 pm; edited 3 times in total (Reason for editing : Added more info...)

Posts : 43
Join date : 2010-05-28
Location : North Dakota, USA

Back to top Go down

Getting GPS Started Empty Re: Getting GPS Started

Post  SecretAgentMan on Tue Jun 15, 2010 6:54 am

I've been using a TouchPro 2 (Verizon) without any issues. It sounds like your GPS isn't properly configured on the phone. The TouchPro 2's GPS is not locked down and should work with any application if it is properly configured.

The best way to test to make sure it's the phone and not GCz is to see if the GPS works with another application. Does the GPS work with Google Maps? If it doesn't, it's a configuration issue.

To check the configuration, go into Settings, System. Under Location Settings, make sure that the Location Service Settings are set to "On".

Go back to Settings, System. Under External GPS, Programs tab, set the GPS program port to COM4 (it looks like yours is trying to use Com0???). On the hardware tab, the GPS hardware port should be none and the baud rate 4800. On the Access tab, Manage GPS automatically should be checked.

By default, Location Settings are turned off. The first time you turn it on, you'll have to OK a box indicating that you've turned it on. If you've never used the GPS on your phone, this is probably the issue.

When you start GCz, look in the lower right corner of the main screen below the "Nicque". When the GPS is active, you'll see blue bars indicating reception. If they are grey, the GPS is not locked. If your GPS is configured properly, just not locked, you'll get a "Failed to Initialize" message when you do something in GCz that requires the GPS. You'll never get the error message you did if the GPS is configured properly.

Every once in a while, the GPS has difficulties getting a satellite fix. The very first lock sometimes takes a while too. Your phone shipped with a program called QuickGPS. This downloads satellite data to help the GPS get a quicker fix. Run this regularly. I find that sometimes when I can't get a fix, running this app usually gets the GPS to fix immediately after I run it.


Posts : 37
Join date : 2010-06-09

Back to top Go down

Getting GPS Started Empty Re: Getting GPS Started

Post  Sponsored content

Sponsored content

Back to top Go down

Back to top

Permissions in this forum:
You cannot reply to topics in this forum